Discussion Forum

Installation lzma compatibility problem

To add questions or replies, please log in.


Post author:
Text in post
Post date from: to: (dd.mm.yyyy)
Installation lzma compatibility problem
Hello, I'm trying to install VariCAD to a PCLinuxOS 2010 32 bit machine and run into the following problem (command as shown):

rpm -ihv VariCAD_2010-en-2.08-1.i586.rpm

error: Failed dependencies:
rpmlib(PayloadIsLzma) <= 4.4.6-1 is needed by VariCAD_2010-en-2.08-1.i586

PCLinuxOS, like RHEL 5.5 (afaik, with slight variations) runs the following versions of the relevant software:
liblzma2 4.999.9beta
xz 4.999.9beta

is there a suggested fix or version and distro of Linux that does not have this problem? I really want to try it as I haven't looked at VariCAD since 2008 and the updates sound compelling.
supported distributions of Linux
Hi Carlos,

VariCAD has not been tested on PCLinuxOS. The current VariCAD 2010 2.08 has been tested on Ubuntu, Kubuntu, Fedora and openSUSE. We recommend that you use the latest versions of these distributions of Linux.

Best Regards
Installation lzma compatibility problem
Have you sorted out your problem to get VariCAD_2010-en-2.08-1.i586 up and running in pclos2010.07?

I had the same problem, and you have to bypass the error message, this is difficult if you are not really program minded. It can be done and the system runs fine now for me but it needs some manual help to get it installed.

Search the pclos Forum and you will find out.


Have you changed compression in rpm since earlier versions ?
Installation lzma compatibility problem
Can you please advise what version of rpm is used to make the last distribution version of VairCAD?

rpm 4.4.x or 4.4.6

Getting closer to solve the "LZMA" problem