Discussion Forum

Installation problems: Failed dependencies

To add questions or replies, please log in.


Post author:
Text in post
Post date from: to: (dd.mm.yyyy)
Installation problems: Failed dependencies
Hello, i'm using VariCAD 2010 V2.01. I tried to install some days ago the V2.08 and later the new one V3.00, but had a lot of Dependencies problems.
I use Vector Linux 6.0. Anyway i installed on another machine Slackware 13.0, but had the same problems even if Slack13 has per default rpm version 4.7.
In our company, we use only Vector Linux 6.0 (or at least we can use Slackware) mainly cause the hw is not really new, and such distros are faster and more stable than others.
This problem should be solved, indipendently from the customer distro , if we will able to know the exact dependecies for each version of VariCAD.
I didn't try other version (V2.03), cause i missed it, and also cause there is no way to download a previous version. I think it will be a good idea to let customers to download also previous version (at least the versions of current year, and it won't require soo much space like a full linux distro).

Hope you will consider this suggestions to solve these problems for all customers, and mainly cause customers don't have to be forced to use a different distro.



LZMA compression problem
Hi again.

I tested Version 2.03 and works. The followings has the lzma dependecies problems.

I think that repacking the RPM, with LZMA compression disabled will solve the problem. Hope so.

Why not try?

Thanks in advance


Installation problems: Failed dependencies

The current VariCAD 2010 3.0 (or even v.2.08) requires newer libraries than v.2.03.

Neither Slacware nor Vector Linux are supported systems - VariCAD has never been tested on them. We can just recommend that you use one of the supported distributions of Linux (e.g. Ubuntu, Kubuntu, openSUSE or Fedora). On these distributions VariCAD is tested.

Best regards

I have to say that it works very well on such distros, and is fast too on a P4 with 2Gb ram, and 256Mb Nvidia AGP card. We have old machines, so VectorLinux is the only os we have on all computers. Other distros are too slow to work on, also with lighter apps like AbiWord. I have an hp notebook with 2coreduo processor, 4Gb ram, Nvidia Quadro Fx1500M with 512Mb, and on such machine opensuse is really slow also to open the menu. I think that we should know the exact dependecies to solve the problem and let us use any linux distro. And also lzma is an issue, so probably making an rpm without lzma compression will remove rpm version problem.

Hope you will be able to supply the correct informations.

Best Regards

Mattia Zucchelli