Discussion Forum

Ubuntu spacenavd driver for 3D space mouse

To add questions or replies, please log in.


Post author:
Text in post
Post date from: to: (dd.mm.yyyy)
Ubuntu spacenavd driver for 3D space mouse
After installing the VariCAD.deb package
check that VariCAD works.

Uninstalled spacenavd.deb if you tried this

apt remove spacenavd if you tried this but it apparently did not work

delete spacenavd instances (whereis spacenavd)

Then start again with:

sudo apt install spacenavd

Check that it is installed

:~$ spacenavd -v -d
Spacenav daemon 0.6
failed to open config file /etc/spnavrc: No such file or directory. using defaults.
Device detection, parsing /proc/bus/input/devices
found usb device [46d:c626]: "3Dconnexion SpaceNavigator" (/dev/input/event7)
adding device.
failed to open device: Permission denied
removing device:
adding device.
failed to open device: No such file or directory
removing device:
failed to find any supported devices
failed to bind unix socket: /run/spnav.sock: Permission denied
trying to open X11 display ":0"
^Cclosing X11 connection to display ":0"
:~$ whereis spacenavd
spacenavd: /usr/bin/spacenavd /usr/share/man/man8/spacenavd.8.gz

Do this to fix the problem:
:~$ sudo ln -s /home/username/.Xauthority /root/.Xauthority

Reboot and start your 3D app and the 3D mouse works!

The last step should be included in the Ubuntu package.

Ubuntu spacenavd driver for 3D space mouse
Dear John,

Thank you very much for this useful information. I hope, it will help VariCAD users make their 3D device working under Linux.

I have been reported about custom drivers that are freeware and shall also work:


So there are alternatives.

Have a great day and thanks again.

David Zaplatilek
VariCAD Support Team