Discussion Forum

Some problems with 2018-2.11 and 1019-1.03 (versions with new icons)

To add questions or replies, please log in.


Post author:
Text in post
Post date from: to: (dd.mm.yyyy)
Some problems with 2018-2.11 and 1019-1.03 (versions with new icons)
I'm using Varicad on Linux since 2005 and there generally it was working more stable over the years. But when I upgraded to 2018-2.11 (it had unfamiliar icons in GUI, but luckily in the same places) I've got some problems that were not there before. Upgrade to 2019-1.03 did not fix them.
1) Crash on some files, usually when I try to save file, I tried "Reparation tools" without any luck. As the code is proprietary I could not troubleshoot it and provide detailed diagnostics.
2) Old versions always remembered last new 3D object position and orientation, so when I insert a new one, it will be placed at the same 3D point, the new versions do not.
3) I can not switch between "dirty" windows without saving files. This is where it is annoying: I open some assembly as a reference, without intention to save it and then change some parts to wireframe. And as the assy is considered modified, I can not switch to other window
4) More complicated editing of the part in assembly files, in old versions I could modify part both ways without any extra commands.
5) Several times copy-paste did not work - when I tried to paste, it pasted some other files - and when I repeated, it was still doing the same. Copying - all seems OK, command successful, but pasting was inserting unrelated file contents.

In addition there are few suggestions:
1) In some old versions it was convenient when threads where red regardless of the selected color, now it is possible to change thread color, but then it applies the same color to all other objects, holes, fillets, etc. Is it possible to remember color per type? At least for the threads?
2) I would love that snap mode (center, end, middle,,,,) would be persistent, so the next default snap would be the same as selected for the previous 3D point. It is somewhat better that now it is possible to use context menu to select snap to center, but still it is extra click. I noticed that I use center snap more often then other modes, and it is very often that I measure distances between multiple centers, and each time I need to select center mode again.
3) The feature that I hope to see every time I upgrade the program: command buffering. I have to click very slowly (even on fast computers), because program discards all the new clicks if it did not finish the previous command, instead of buffering them.


Re: Some problems with 2018-2.11 and 1019-1.03 (versions with new icons)
Dear Andrey,

thank you for your report. Let's resolve your questions.

1) Are those files completely created in VariCAD from scratch? If you have imported any STEP file, usually the STEP is a source of problems. Please send us any STEP file, that is opened corrupted or terminates VariCAD. The VariCAD development team makes enhancements to the VariCAD STEP importing feature and such files help them find the issues. The second most probable scenario is a problem in the Boolean tree of one of your solids. Check this short video for more info on the Boolean tree: https://youtu.be/EWFryWyDFt4

2) This is only a matter of settings: Tools/System Settings/Solids Location Settings - check the "Insert new solids at location of previous insertion"

3) Well, the saving has not changed either if I am not mistaken. Whenever you modify a file, that has an assembly link and try to switch to another VariCAD file, VariCAD either saves the file automatically or warns you that if you want to switch to the next file the current file has to be saved. That is why the info pop-up window is active as a default - VariCAD users has to keep the fact, that VariCAD will automatically save any such modification. To turn off this particular message, go to: Tools/System Settings/Assembly Links Settings - and check "Confirm saving of changed part (detail) or sub-assembly files"

4) It is a bit more complicated, but it brings new posibilities alnog that we hope outweight the slightly more complicated behaviour. I will try to explain it on a few examples. For Details that are inserted on the highest level (the currently opened assembly), you have now the option of "Edit in assembly enviroment" instead of the usual "Edit". The new option opens the Detail in the assembly enviroment along with all the solids of the assembly, which are distinguished in different colour. You can edit and transform all the solids and decide at the end, whether you want to keep the changes made on the Detail or not. All changes made to the assembly files are not kept. This gives you more dynamic enviroment for testing out solutions without having a fear of making a mess in your assembly.

All sub-assemblies can be edited in the assembly enviroment now. Before that, all sub-assemblies had to be opened separately - not having the option of confronting with parts of the assembly directly during the edit.

Lastly, there is a new option for opening Details, that are inserted in sub-assemblies. In the former version you had to right-click the sub-assembly and select "Open as part file from assembly" and then open the Detail the same way once again or until you got at the level of the Detail (in case there is more levels). Now you can open Details of any level from the "Assembly Tree Scheme" (command asrt). Just right-click the solid you wnat to open and select "Edit in assembly enviroment".

5) Does it persist after reboot of your OS? It seems unrelated to the changes that has been made between the 2 latest versions. Have you been able to isolate the trigger?

1)This has not changed also. Execute "sco" in VariCAD or go to: Tools/Color and Wires of Solids, Threads

You can choose if all parts of solids are coloured according to the base one or that each has its own colour. And besides that you can set colours of threads, library parts, fillets and chamfers independently.

2) The exact idea has been already discussed in the development. It is not probable to be changed in the near future. Our experience is that some users prefer if the snaping filter would lock on a type, some not. VariCAD development prefers the latter, as it is more flexible and does require the same amount of steps to proceed. (case locked: just select a point at a circle by left mouse click - selects the centre; case no filter locked: hover your cursor over the circle, hit 5 or @ at your keyboard)

It is the same amount, but the current settings gives you the opportunity to snap any filter at any time without the need of turning it on and of repeatedly.

3) This really should not be a problem even on slower setups. The response is quite fast for a human user. I am not sure what is the case when using macros, but I am not sure how much sence does it make for a CAD software to be accepting commands during another command execution and storing them in queue. Furthermore, you can create the timing in the macro code itself.

There was a problem slowing down VariCAD significantly related to an icon loading procedure in Windows, but it was patched in the VariCAD 2018 1.03 already and should not affect future versions.

Let me know and good luck!

David Zaplatilek
VariCAD Support Team
Thank you David
Thank you David for your answers, I'll try you suggestions.

Yes, I imported some step files for the connectors from the manufacturer web sites, it would be nice if Varicad could at least tell this before crashing. I will try preprocessing STEP files in FreeCAD before importing them into Varicad. We use FreeCAD now for converting Varicad-generated STEP files to x3d ( https://wiki.elphel.com/wiki/Elphel_camera_assemblies ) and custom-filtered stl for 3d-printing - it has Python very handy for writing your own code: https://blog.elphel.com/2015/12/x3d-assemblies-from-any-cad/

No I did not try to reboot computer - I do not do it often - only when system upgrade requires reboot.

>some users prefer if the snaping filter would lock on a type, some not.
Then why not to make it a boolean configuration parameter? Or even bring it to a context menu? As I wrote I noticed that I often have to snap to centers of many consecutive points.

With slowing down - it is not slowing down, overall performance seems OK, it is just that - not buffering mouse clicks, and that is annoying that I can not "click-and-forget", but have to wait for the command completion. Can you imagine a keyboard dropping characters if you type too fast and have to visually verify that each one appeared on screen before pressing a new one ? I do not think command queuing is difficult to implement.

I did not use any Varicad macros.

I can not see slow-down for Windows as I use only GNU/Linux since the beginning of this century, and this is the reason I use Varicad that has native Linux support. For MS Windows there are many other mechanical CAD programs.
Can not save/save as
Got another problem with forcing to save. I wanted to change color of the part in the assembly (previous versions allowed it), not the color of the part in the library. When I opened the part file and changed color there Varicad was demanding to save the file. But it got lost somewhere in symplinks and failed to save the file (when opening assembly it did not report any missing links). It does not let me "Save As" to select a new name. It is also unfortunate that it does not let me select and copy error message and the problem path from the error message box : "File ... can not be saved - check if ..." - I checked that it exists, not write protected, not "shared by another program" and device has plenty of space.

So at this step Varicad does not let me save or save as or switch windows. Luckily, my edit was small. so I closed it abandoning changes.

Still crashes, even w/o STEP import
I created 48 boxes, boolean added all of them to a larger box, and then tried to scale this solid by 0.5. "Can not modify..." and immediate crash. Tried several times, the scene contained just 2 copies of that solid.
Re: Still crashes, even w/o STEP import
Dear Andrey,

I think that this is due to some Boolean tree anomaly. I have tested to add boxes in such a way, that you add the periphery ones first, engulfing one box. If you add the engulfed box at some point, VariCAD crashes. I will direct the bug to our development.

Every time, you edit any complex solid, the Boolean tree is reassembled, which in case of a too complex solid may result in issues.

The advice is to keep the Boolean tree as simple as possible.

David Zaplatilek
VariCAD Support Team
Still can not get stability of 2017 version
David, I sure try to keep boolean tree as simple, as possible but I still can not get stability of the older 2017 version and consider to downgrade to that older version - it seemed to work better for me (will have to use some export/import for the last designs I did with newer software to be able to open them with 2017 Varicad.). Difficult to measure exactly, but it looks like "Can not modify solid" (without reason - what exactly Varicad did not like) more often now than it was with 2017 revision.